Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

BTB output level
pold
#1 Posted : 6/3/2014 7:14:18 AM

Groups: Member
Joined: 5/22/2014(UTC)
Posts: 2
Location: Mérignac
Hello ,

I'm a newcomer with a btb 405 qm which I recently bought second hand. The bass needed a little oiling, cleaning, new batteries and a set of new strings. It's now in a perfect condition. When I plugged it for the first time in my amp, I found the output level was a little weak. All the controls seem to work properly. After a few days I got used to it : the volume knob is always at full power on the bass. But when I plug the SGR 180 with the same settings on the amp, it turns out much powerfull.

According to an active membre of this forum (namely bill@ibanez - if you read this, thanks once again Bill ! The wiring fits to the scheme you sent me), this could be the instrument natural sound. Now, has anyone noticed this or am I just expecting too much ?
Mr. Abner
#2 Posted : 6/5/2014 12:45:43 PM

Groups: Member
Joined: 9/3/2012(UTC)
Posts: 217
Location: Mississauga
Thanks: 6 times
Was thanked: 22 time(s) in 22 post(s)
I can't say anything specific about either bass models you have, but indeed different instruments have different output levels. My MC-924 in passive mode has a much lower output than my RS-924 (also in passive mode). That's just the way it is with different pickups.

And I've yet to come across an amp I can't turn up enough to be heard. :)

-Alex
pold
#3 Posted : 6/10/2014 8:00:33 AM

Groups: Member
Joined: 5/22/2014(UTC)
Posts: 2
Location: Mérignac
Tank you for your contribution. By the way, it's a very good instrument, easy to play and with a smooth sound. Maybe a little heavy but I think the weight also have a good influence on the sound... JF
Sliide90027
#4 Posted : 5/8/2015 5:25:43 PM

Groups: Member
Joined: 5/8/2015(UTC)
Posts: 4
Location: Dallas, Texas
This has been an ongoing thing with me.

I have 4 BTB's, 2 with the Dynamix and 2 With Barts.

My Main Bass, a 456 (with Barts) is considerably weaker than all of the others even with New Batteries.

I have endured this a long time and am about to just by 2 used basses for hardware and Electronics to switch out.

I barely play the 455 and should just do the switch out on that one, but I would play that one in a pinch.

The hardware finish and this inconsistency is the only beef I have with the 400 Series Instruments I have, and even prefer the Walnut stability over the Bubinga Stringers in the 1006 I have.

Still, the tone I am getting puts me in a position of wishing for a reissue of the 400 series - Walnut Stringers, Variable Midrange, Bolt on Neck to be shimmed to bring ultra low (Nap of the Frets), Basswood Clarity, QM Top.

I played a top of the Line Ken Smith. No Joy, just like the Neck Through BTBs of present.

I Played a Bolt on Smith. Now that was as inspiring as my 456. But why spend the $3K more to get it?

Bring em back Ibanez. These were and still are the peak for me.
Nighttrain1127
#5 Posted : 4/18/2016 11:51:28 AM

Groups: Member
Joined: 7/24/2015(UTC)
Posts: 3
Location: Near Worcester, MA
I have the same Issue and was wondering if there might be a gain pot on the Preamp? Does anyone know? The output is extremely low for an 18V Pre.
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.