Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New to forum, new to Ibanez - SA2020
Fiery Music
#1 Posted : 1/30/2017 9:47:54 AM

Groups: Member
Joined: 1/30/2017(UTC)
Posts: 3
Location: Australia
Hi All

I've just picked up my first ever Ibanez and it's a real weapon. It's a Prestige SA2020 - great neck, great feel, and oozes quality. Has upgraded Seymour Duncans pickups plus a kill switch installed. I put some locking Gotohs on it too. I think it's a keeper.

Now for my questions. I noticed that certain guitar leads don't fit the output jack well. They insert but there is some play and the signal cuts out, exactly as if the lead was damaged. I've double checked my leads and they're all fine. About half of what i have work fine, the other half cut out.
Has anyone ever experienced this and have a possible solution?

I also have a Line 6 G10 wireless unit but the plug doesn't fit due to the deep recess. Is there a replacement jack that would extend out of the recess so it's not so deep?

Any advice would be very much appreciated.

thanks, Dean
Bill@Ibanez
#2 Posted : 1/30/2017 3:11:34 PM
Bill@Ibanez


Groups: Moderator, Administration
Joined: 6/19/2012(UTC)
Posts: 2,578
Location: Bensalem, PA
Thanks: 36 times
Was thanked: 411 time(s) in 401 post(s)
The loose jack/cables you are running into may be the jack itself. I usually don't come across this issue very often, but sometimes the cable ends are a slightly different size and may not fit as tight. More importantly is that this is usually a problem with the jack itself being too loose. Replacing it with a new one would be the best option to try and fix this.

As far as the recessed issue, I don't know of any way to 'extend' the jack that is in there. A more severe/permanent solution would be to relocate the position of the jack to be somewhere easier to get to. Otherwise, you may be able to use some kind of extension to run from the current jack to your Line6.
Fiery Music
#3 Posted : 1/30/2017 8:12:11 PM

Groups: Member
Joined: 1/30/2017(UTC)
Posts: 3
Location: Australia
Thanks for the reply. My current solution is to only use the leads that work with the jack. It's a few so that's probably easier than replacing the jack or relocating it.
As for the G10, I actually made an extension piece which is basically male and female 1/4" plugs joined with a really short lead, and then strengthened/covered in heat shrink. It works well. I've included a couple of photos:
Extender

On the SA2020
Originally Posted by: Bill@Ibanez Go to Quoted Post
The loose jack/cables you are running into may be the jack itself. I usually don't come across this issue very often, but sometimes the cable ends are a slightly different size and may not fit as tight. More importantly is that this is usually a problem with the jack itself being too loose. Replacing it with a new one would be the best option to try and fix this.

As far as the recessed issue, I don't know of any way to 'extend' the jack that is in there. A more severe/permanent solution would be to relocate the position of the jack to be somewhere easier to get to. Otherwise, you may be able to use some kind of extension to run from the current jack to your Line6.



Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.