Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

SRTc issues
juddfellow
#1 Posted : 11/16/2017 2:51:38 AM

Groups: Member
Joined: 9/17/2010(UTC)
Posts: 7
Location: Raleigh
I'm more of a lurker than a poster, but my lurking has not yet helped me fix this thing. I have a spalted mango acoustic/electric guitar from the EW series that i bought new in 2010. I play periodically, and found that the preamp/tuner will not turn on, regardless of whether I put new batteries in or not. Am I SOL or is there a fix?

Think
RIX
#2 Posted : 11/16/2017 4:54:13 PM
RIX


Groups: Member
Joined: 2/8/2010(UTC)
Posts: 496
Man
Location: California
Thanks: 8 times
Was thanked: 56 time(s) in 56 post(s)
Hello juddfellow,

I am not certain on this, but it maybe that you have to have a cable plugged into the guitar to get the tuner to work. Have you tried that?
RIX
juddfellow
#3 Posted : 11/17/2017 1:47:05 AM

Groups: Member
Joined: 9/17/2010(UTC)
Posts: 7
Location: Raleigh
I have, and still nothing. However in the seven years that I've owned it, it has always turned on regardless of being plugged or unplugged. I put in a new battery and it wont turn on. The button that is the "on/off" switch won't stay down when you pressed.
RIX
#4 Posted : 11/17/2017 4:39:08 AM
RIX


Groups: Member
Joined: 2/8/2010(UTC)
Posts: 496
Man
Location: California
Thanks: 8 times
Was thanked: 56 time(s) in 56 post(s)
I just check my guitar and the on button for the tuner does not stay down like the Phase and Chorus buttons.

Sounds like you're not getting power from the Output jack and Battery holder.

Check out my post on the SST and SRT battery holder output jack.

http://forum.ibanez.com/yaf_pos...ttery-holder-Issues.aspx
RIX
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.